Start a new topic

iOS app not accepting FreshPhone credentials

I have recently upgraded to a new phone. The updated iOS app (v 1.0.5) is not accepting my FreshPhone account credentials to set up an account. Error message: "Verification Failed  A value must be entered." I have the correct login details, as logging in to tms.freshphone.co.za still works.


I have also tried entering the SID details to log in, but with the same result


The app has been working on my existing phone and I am still receiving calls. I am not sure if the problem is that the app needs to be deleted on the existing phone before the account can be used on another device. Understandably, I am cautious about doing this in case I am left logged out on both devices.


Please advise.

1 Comment

Hi Pia,


I think the issue is when you restore a new phone from iCloud, it restores the app as logged in but not authenticated, I had this same issue. Just open the app and reset it, log in again and it should be resolved.

Login or Signup to post a comment