Start a new topic

Registration Failed Error


I'm currently permanently getting a registration failed when trying to connect from my home internet.

If i switch to 3g and use the built in dialer on the freshphone tms web site it works, but on my home isp it doesn't work at all.  I also can't get my yealink to register anymore either.

Does freshphone do some sort of IP rate limiting?


Similar issue. Though I have had a nightmare trying to get devices to register to tms.freshphone for the last while. Just strange that the same settings on the handsets end up giving failed registration :/

Busy setting up a gigaset 540IP which had my test freshphone credentials configured for testing. Registered fine when I first placed teset credentials but now when registering a new account for the client the new accounts credentials are unable to register. Swapped back to the test account's credentials and now cant get the device to register to freshphone on either of the accounts (new test / test account).

Hi All,

There are certain factors that are in play that can cause the registration to fail. Incorrect SIP credentials, the ISP has disabled SIP traffic to go through (i.e UDP over port 5060) or too many failed registrations can cause the system to blacklist the IP address.

Hi Vasili

"Does freshphone do some sort of IP rate limiting? "

No we don't. It is normally a router firewall issue. Due to failed login attempts with incorrect credentials, we may have blacklisted your IP address. Go to google and type Whats my IP and then send it to and we can check the blacklist.


We experienced a power failed and since restarting the yealink base station, the phone refuses to register again with registration failed errors.

I can ping the address with 80ms response times which I assume should be adequate.

I have tried changing the SIP address to the public ip of the sip server, changing the port to 5090 and resetting up the password.

I have also sent an email to with my public IP address that Im coming from.

Hi Vincent

I have taken a look at the ticket logged which confirmed your Public IP was initially banned but has since been removed from the backlist.

Good day, I have been trying to register my handset but it keeps on saying that the registration has fail. I tried twice and I don't know what to do anymore. Kindly assist

Hi Boitumelo,

Please note that I have replied on a private ticket for you.

Login or Signup to post a comment