Start a new topic

Registration Failed (FreshPHONE & Zoiper)

My FreshPhone app is not working, it keeps flashing red and green. When I check online it shows Offline Status. 


I have also tried Zoiper, it shows status FreshPHONE is registering then moves to registration failed, the whole process keeps repeating.

I found topics similar to mine on this forum and you guys are saying we should send an email to but I get an automated response saying This email channel will only cater for tickets relating to Billing and Porting, technical enquiries will be automatically closed.

I see that you have managed to get the account online.

Hopefully it stays up please do contact us if you have any issues.

I also have 2 of my numbers that seem to have stop working. Registration failed. Did work before.

The ones ending with 516 and 180 are the problem ones. Others still working fine.

Hope this can be fixed as the 516 is linked to a ported number for our B&B.


Please could you provide us with your public IP address in a ticket I would like to check if you public IP is being black listed.

But please do via a ticket would not like you r personal details out in the open.

I can send public IP but tested with cell c MTN and ADSL. Other numbers on that account work fine on all three ISP's
I also forwarded calls that are made to my ported number to my cellphone. But when I phone the ported number it tells me this is not a valid number on euphoria network.

still same problem failed to register with line numbers ending with 516 and 180

Also if one phones the number ending 516 it says this number does not exist on euphoria network ?

My ported number ending 2565 also gives same error.

Hi Rory

The 516 and the 180 accounts needed a reset. I have reset them and I am just waiting for Dev to match the passwords to the last password and to remove those 2 accounts from our blacklist. They have just let me know that it has been done. Those 2 accounts will work now.


How do I get a permanent solution to my failure to register issues on both a Yealink device and Zoiper app.

The last time I had to go as far as going via Euphoria support who as a gesture of goodwill assisted me.

Again after resetting my internet connection due a replacement of the UPS we are back to square 1 with a registration failure.

How do I get support from freshphone or do I have to rely on Euphoria to get help? Or do I need to create a new account. What is the problem with my account?

Hi Vincent,

Please advise on the make and model of the router. There were settings configured on the router and after the reset the settings have been lost. 

Login or Signup to post a comment