Start a new topic

Registration Failed (FreshPHONE & Zoiper)

My FreshPhone app is not working, it keeps flashing red and green. When I check online it shows Offline Status. 


I have also tried Zoiper, it shows status FreshPHONE is registering then moves to registration failed, the whole process keeps repeating.

I found topics similar to mine on this forum and you guys are saying we should send an email to but I get an automated response saying This email channel will only cater for tickets relating to Billing and Porting, technical enquiries will be automatically closed.

Please try again, I was able to register on zoiper now.

Registration failed (Request Timeout (408))

I have the same issue. I'm not very familiar with SIP setup but all was working from the tms dialer. Then I tried to register via another device and I'm unable to register via the Freshphone dialer or the softphone. Can an account get locked out? 

Hi Fresh Man, any feedback on these issues, I see for some people you asked that they provide you with their numbers cause you had issues with the servers. Can we get assistance or these are the effects of free things.

Hi Mthoe,

The error 408 Request Time Out that you are receiving means that your internet connection is taking to long to reach our servers. The flashes of red and green are a notification that the app is trying to connect however it is failing to breakout.

Please try using either your mobile data or WiFi and not both at the same time as this can cause issues as well. 

I have tried different connections but still not working. It was working perfectly before on my Mobile Data.

Hi Mthoe

I tried to register your account on Freshphone app and it worked. I tried a Yealink and it worked, I tried the browser phone built into our TMS and it worked. I tried on an LTE connection, on a fibre connection and on a mobile hotspot connection. All of them worked.

Here is a screenshot of the browser phone online status. The only things that could be causing your issue are your internet connection or your device is faulty.

Hi Fresh Man, thank you for testing. So obviously the issue is on my side. I will see what I can do but clearly it works. Thank you for all your help.

Hi Mthoe

Which model mobile phone do you use and please check your firewall settings on your router to ensure that SIP ALG is disabled. Also, have you rebooted your mobile phone recently?

Hi Fresh man

I have actually checked other connections and they are working, I need to check my LTE again when I get my data on the 1st. As for the WIFI I have no access to the Firewall as this is a work connection.

Hi there Mthoe ncube 

Please advise us once you checked the Lte connection on the first .

The wifi connection shouldn't be a problem .

Good Day

I have tested on my LTE and it connects but the connection is intermittent. I assume the issue is with my network provider.

Hi Mthoe

I would assume so as well

Hi, I am having the exact same problem, I have tried both apps, no luck and I have tried 2 different wifi's and mobile data and still not working. Something is definitely wrong with my account
Login or Signup to post a comment