Start a new topic

Need help setting up ATA adapter KTA3000

Hi. I have tested the Freshphone app on my cellphone and it has been working for a few days now without issues, although it seems to be having difficulty registering today. I have 10mb FTTH connection with mweb.

That is however not my concern right now. I have an unbranded ATA called KTA3000 that I have used successfully in the past on another network. For the life of me I can't get it to register on the sip server. I have tried,, without success. I'm sure my account settings are also correct as it's exactly the settings used on the mobile app. 

My router is a Western digital N900, yea I know not a common router. However ALG doesn't seem to affect functionality of the service from my experience of testing with the app switching between on and off.

Would really like to get this working as I prefer to call with a normal handset as opposed to mobile app.

I have attached my current settings. Maybe I just missed something.

Would appreciate any help.



(190 KB)
(236 KB)
(230 KB)

Best Answer

Hi Francois

The password has been shortened and updated

Always a pleasure

Will do, thanks for your help with everything.

Hi Francois

It does sound like an issue with porting. Probably coming from one provider. Send a mail to and send a fresh example of your call fail. With the following:


Caller ID of origin:

number of destination:

Hi Fresh Man I'm not receiving incoming calls on my 021 no. When dialling I get "the number you have dialled is not in service" however the 087 no incoming calls and everything seems to be working fine. Could it be a porting issue?

Hi Francois

No need to change anything. It has been allocated to your 2787 account and I see that you have made it your Caller ID. It should be working well

Hi Fresh Man

Yes, at long last we got it working!

Now I just need to figure out how to use the ported 021 number.

I can see it is activated under DID, do I need to change anything on the device on my side?

Thanks a lot for your help!

Hi Francois

It seems your hunch was correct. It is now registered on the Koncept


Hi Francois

The password has been shortened and updated

Hi Fresh Man. Completely forgot to reset the app. Did that, but the ATA is still not registering. Would appreciate if we can try with a shorter pass. Could you please reissue a new pass. Thanks

Please reset your Freshphone app. Please also not you cant use the app in conjunction with a desk phone, the app will keep the registration alive and your desk phone will barely ever get an inbound call.

We can remove the last character of your password if you would like to test that?

Hi Fresh Man.

Thanks for replying. I tried without the outbound proxy but no luck unfortunately. ALG is disabled. Did manage to get a dial tone though by unchecking Registration Request - was giving constant busy tone prior to that. Still can't make a call.

One thing that's bothering me is the WAN light on the ATA continuously blinks at a slow constant pace. Could it be it's not seeing the network? WAN is configured to dhcp and gets assigned with ip addr, WAN status page does show the link is up and active.

I have noticed something. I have a voip desk phone that I'm trying to get working now. The desk phone seems to accept a password of 16 characters max. When I input my Freshphone password I cannot type the last character - if I counted right my Freshphone pass has 17 characters. Could that be also causing the problem on the ATA?  The ATA and desk phone are from pre-2010 era and perhaps does not support long passwords. Maybe I can try a shorter password...

For further reference I have attached my traceroute result and other sip settings.



(189 KB)

Hi Francois

Have you tried without the Outbound proxy? Also, please disable SIP ALG as it rears its ugly head when you least expect it.

Login or Signup to post a comment