Start a new topic

Freshphone app not working 100%

I am using the Freshphone app, and it works really great except for the speaker button that is not functioning. I have tried all scenarios to enable it, but cannot. I have been trying it on different phones and models too and still I cannot get the speaker to activate.

Hi Michael,

I tested this on both android and iPhone and was able to able to hear and be heard on loudspeaker. I believe it may be permission related. When installing the app please make sure you allow all permissions for the app to function correctly.

Please re-install allow and confirm if its working?

Reinstalled and still not working. Running Android 9 on Huawei Mate 20 Pro. Tried it on Galaxy S10 and also not working.

Hi Michael

I have tested now on multiple devices including S8 S9 and S10 all running Android 9 and they are all working. I need to be able to replicate the issue in order to troubleshoot it. 

For some reason my post was not loaded.

I can activate the speakerphone when I get incoming calls, but outgoing the functionality is gone. So there is something strange with the app.

Hi Michael

I tried now and got an issue, got all excited that I had replicated it, but then turned off my WiFi and went with mobile data and it worked fine. Seems my WiFi was blocking outgoing audio. Tried successfully a on S8+, S9+ , S10  all on Android 9 and a Huawei P9 lite Android version 7.

The fact that it's not working on multiple phones for you, makes me think it has something to do with connectivity/firewall

Hi Fresh Man

Will try it on data and let you know. Thank you fro the help.

Hi Fresh Man

I am still using the same WiFi network, and all of a sudden, the speaker phone option started working for outgoing calls. Nothing has changed. So it is very strange indeed.

But everything is working. Thank you for checking this for me.

I installed the FreshPHONE app about a week or so ago and registered it on my iPhone XS Max. It has only ever worked once when I tested it to make and receive a call. Ever since all I get is either "call unauthorised" or "Error". I have not changed any settings on either the app or network, what could be the problem?

Hi Karlen

We are dealing with these on a case by case scenario via email/tickets. If you haven't already, please send a mail to

There might be info that we require which should not be put on a public forum

Login or Signup to post a comment