Start a new topic

Registration keeps hanging or failing


I have followed all the steps however when I try and register my base the process keeps failing.

I have a Cell C RTL30VW LTE -A Home Router.

I have gone into router IP via browser, Network>NAT/Firewall>NAT Passthrough>unticked SIP & save & apply

But nothing seems to work. Base won't register.

- I've NAT Traversal by setting NAT to STUN on base IP menu. Doesn't work

Hi Harvene

Have you tried to turn your Firewall level lower? Our servers could also have blocked your public IP address if you entered the credentials incorrectly. Please also let us know which base you are trying to register


I have lowered firewall settings, but doesn't seem to work. Credentials were entered correctly.

The base is : Yealink W52P | W56P

The phone is: W56P

It seems the Cell C router doesn't have VoIP functionality?


I have tried a new router. The handset did register on Account 2 on Yealink base, but it was trying to register on account 1 as well. The device status was online on freshPHONE but it's gone now and won't work anymore. Maybe it picks up our phone IP as registered when it is not because phone is still not working

Please assist on Fresh Phone end

Hi Harvene

It must only be on 1 account, not 2. Also, if the credentials are slightly incorrect on the one account, our server will block your IP address. Please send your public IP address to and ask us to see if it is blocked. You can find out your public IP by going to google and typing in Whats my IP

Thank you trying that now

Hi Harvene

IP was blocked, it is unblocked again


Here's the update:

Cell C came today & connected whole new router Huawei B315, we reset the base and deregistered the phone. We turned off the firewall on the router and we unticked the SIP ALG. We did everything from scratch, no errors in inputting username & passwords & SIP connection but the "Registering" keeps showing until it eventually fails.

This seems to show that the fault must be on the FreshPhone side. Is our IP definitely unblocked? Have you reset all our data and deleted our accounts because we were registered for 20 seconds on Monday then everything stopped working.

We have done everything on our side. This issue remains with registering

Hi Harvene,

I hope you are well. We will need to try changing some setting on the phone to see if it combats the issue you are experiencing. Please can you use the physical IP address of the domain which is You can also try changing the local SIP port on the device to 5090 as illustrated in the screenshot below. Please can you send us your public IP address to see if we are not blocking you. Thank you. 

Image result for yealink w52p local sip port


After numerous attempts at registering about 30 minutes after I posted my previous message the registration went through and everything is finally working.

Thank you!

Login or Signup to post a comment