Start a new topic

SIP blocked from foreign location

I am currently travelling and unable to register my freshphone SIP account from the a local Swedish ISP IP Registration fails from all devices.

SIP Registration works fine from other Swedish ISP IPs e.g. Mobile works just fine, so either Freshphone has blacklisted the source IP or my particular swedish ISP is blocking all SIP traffic.

Please confirm if you are blocking foreign source IPs including :

Hi Andrew,

I hope you are well. Please can you try pinging ( from a PC connected to the same internet connection you are trying to register the softphone. 

Thank you. 

Ping works fine:

Sians-Air:~ sianremfry$ ping

PING ( 56 data bytes

64 bytes from icmp_seq=0 ttl=47 time=222.694 ms

64 bytes from icmp_seq=1 ttl=47 time=265.603 ms

64 bytes from icmp_seq=2 ttl=47 time=498.998 ms

64 bytes from icmp_seq=3 ttl=47 time=305.393 ms

64 bytes from icmp_seq=4 ttl=47 time=324.162 ms

As does Telnet:

Sians-Air:~ sianremfry$ telnet 5060


Connected to

Escape character is '^]'.

It looks like its registering now. Did you change/unblock something? Nothing changed on our side.

Hi Andrew

Nothing changed on our side. If you are able to ping our server, then we are not blocking that IP. We do block IP's when there are invalid credentials used to try and register a phone, this is done automatically with no human intervention

Hi Fresh Man

I am also sitting with this problem, i have reset my phone (Fanvil X3S) to factory settings, however when i try to register the phone, it keeps retrying & timing out, i have also restored the 1st config settings which worked however the problem still persist.

ping results:


Pinging [] with 32 bytes of data:

Reply from Destination port unreachable.

Reply from Destination port unreachable.

Reply from Destination port unreachable.

Reply from Destination port unreachable.

Ping statistics for

    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

I have pinged successfully & was also able to telnet however i'm still stuck.

note that i am unable to ping


i am based in South Africa


your help will be much appreciated......

Hi Kabotsa,

I think this was related to ticket where it was discovered we are not the hosts of your account, please confirm if this is the case, if you are still not able to reg with those hosts, you could try one of our accounts?

Login or Signup to post a comment