Start a new topic

Afrihost Fibre - FreshPhone Account Registration Failed - POSSIBLE FIX

Dear FreshPhone Users, 

It has come to our attention that selective Afrihost Fibre installations do not allow FreshPhone users to register SIP accounts as per usual, we enquired with them as to why this was occurring and they reverted with a possible solution for affected users to implement. 

This has proven to resolve any registration issues reported thus far and is quite simple to do, there it is: 

When you are setting up your SIP account on whichever device you may be using, simply add ":5060" at the end of the SIP-Server address, as seen here:

Sip-Username: 2787*******


Sip-Password: *************

Please let up know if this has helped you with your setup. 

Best Answer

VoIP thru ===> FreshPhone & Afrihost are looking up!

Zoiper software phone settings as per QR Code -- plus IP address

Account name :  FreshPHONE


Username:          27870123456                           ( not my real number)

Password:    *******************  (no idea as it is - Set by QR Code process

Outbound proxy:  was the same “HOST” above.

D-Link AC1200 Wi-Fi Gigabit Router settings:

I played with SIP ALG (under security)-switch back to the default “ON”

System seems to be working fine – caused plenty of frustration – Now to look forward to crystal clear voices at an affordable cost. 

(High light text was changed)

Many thanks to all concerned.


1 person has this question

Hi there. AfriHost still does not seem to work. Using 5060 makes no difference. I can get Zoiper working on VodaCom but not on MTN or on my AfriHost fibre system. I use a DLink DIR825 WiFi router and a Huwawei fibre modem with 4 ethernet ports. One connects to my WiFi routers WAN port.

It seems this DIR825 WiFi router does not work


2 people like this

Just signed up with Freshphone and still on Afrihost ADSL, but swopping to fibre. Have tried on my old TP link router currently being used, and on the new Dlink DIR825 provided by afrihost, and so far I can't get any incoming calls either.

I can dial out on wifi. On 3G I can dial out and receive calls.

Hi Oliver

Have you disabled a function called SIP ALG on your DLINK? Normally under Firewall tab


Thanks for the reply.

I have yes (atleast on the older tplink) no change.

Hi Oliver

If you can make calls, but not receive on a connection, but you can on another, it points to bidirectional UDP traffic via port 5060 not being allowed to and from our server by your ISP. 

Your 3G ISP is allowing it, and this is why it works.

You have also tried multiple routers, DLINK are notoriously bad with VoIP, but TP Links are great.

Please try and turn off the Firewall, and try and turn it down to it's minimum and test again

I have a DLink DIR825 with Afrihost fibre. I also use a Grandstream HT802 which I plug my old landline into. It all works well. What I found is that I did not need to disable SIP ALG or SPI or anti spoofing as has been suggested in some Internet posts. My hardware is G1 and firmware is very 7. You must tell the Grandstream to use Tel URl=Phone

HI Freshman,

Thanks I did try turning the firewall off on the TP Link with no luck. I will try it at the end of the month when the fibre line is up and the new Dlink as well. I agree with you it is either an ISP or router issue though.

@Paul, thanks for the input, but I am not quite with you :) Could you please explain how I could correct this? Thanks

Hi Paul

SIP ALG being enabled can work for days, weeks even months, but it does always end up causing issues down the line. You will find that one day your account will not be able to register, disabling SIP ALG will fix it. SIP ALG works well for onsite PBX's, but when you are registering to hosted servers it starts to cause the issues

2 people like this

Oh. I see. I had so many issues getting my FreshPhone account to register. I could not make it work regardless of whether I used port 5060 or not. I even tried to substitute with its DNS resolved IP address of I was thus using combinations of:,, and

Most posts I saw about the DIR825 related to older firmware/hardware versions. I thus guessed that by virtue of its newer firmware/hardware that the issues would be resolved. I even tried to port forward 5060 (UDP), 5061 (SSL).

My one question would be can one use SSL (5061) instead of UDP (5060)? Would one need to set up an SSL Certificate for this?

Here is my Grandstream config pic - note this IP address and not the DNS name and the use of User-Phone:


And below is my DIR825 Firewall setup:


Hi Paul

5061 on our platform uses Transport layer Security ( TLS) It is not active on Sip1 only accepts UDP traffic on 5060

Nat Traversal on your Grandstream ATA should be set to Keep-Alive

Thanks did this (Nat Traversal on your Grandstream ATA should be set to Keep-Alive)

No TLS....well there goes that idea....

I was having the same issues initially with AfriHost and Cellphone data.

Could receive and make calls on cellphone data but could not receive or in my case make calls on AfriHost.

My system seems to be working and stable now...

Hi there. This probably should not go here but it is linked to Afrihost.

We have had an excellent system working well. Vumatel installed the fibre. Afrihost is our ISP.

We ported to FreshPhone on 11 Oct. All was well. My deaf mom in law commented on the clarity of the phone calls to the US and Australia and the cheap call rate.

On Friday 10 November 2107 at 10am I was working when a website I opened came up with a DNS resolution error. I reloaded - frequently. It did not help. We have had extremely slow Internet access with DNS resolution errors continually. Reverse DNS is OK and responds. Forward DNS never works and with nslookup and traceroute gives timeouts. I have been unable to connect my GrandStream HT802 to and it also says not connected as does the portal.

I have been on the phone to Vuamtel and Afrihost for a combination of 40 minutes. Neither can solve the issue. I cancelled my Afrihost package (10M up/10M down unshaped/uncapped). They convinced me to rejoin which I did. But my condition was 12 months free Internet access for the inconvenience.

I have reset the router (DLink DIR825) to factory defaults. This has not helped. I cannot solve this. I cannot get either Vuamtel or Afrihost to help me.

I am completely out of ideas and cannot work as I have no Internet access or phone.

I have set up DNSservers in DIR825 to be and from Afrihosts and

When I use to test the line I cannot load it. MyBroadband Speedtest gives me a latency to CT or JNBof 19ms with 7.9M up and down.

I do not have a 4G modem to plug into WAN port to rule out DIR825 failure.

The only thing I can think of is that Afrihost has changed DNS settings or that they have changed their IP6 implementation as I have seen that before or that I am being subjected to a DDoS.

Does anyone have any suggestions to try?

Thanks in advance and sorry if I posted in the wrong forum.

Is there ANY one out there that has Afrihost as their ISP and can use VoIP (Freshphone)?

I use Afrihost  as an ISP and their "D-Link AC1200 Wi-Fi Gigabit Router" with no luck.. -

I have added 5060 ( - set SIP ALG off, Audio codec to iLBC30 on

I have two profiles - One set up manually and the other via the QR CODE. The diff is User name and password - I manually use my email and pwd -- QR code use the phone no an (a hidden) pwd.

The smart phone all Zoiper fails to register - sometimes complains about DNS time out(503) & 

Request Timeout (408)


Hi Edward, Please try:

I have added 5060 ( - set SIP ALG off, Audio codec to iLBC30 on

With SIP ALG turned on, I saw someone was able to get it to work that way before. Please let me know if this does not work.

Login or Signup to post a comment