Start a new topic

Afrihost Fibre - FreshPhone Account Registration Failed - POSSIBLE FIX

Dear FreshPhone Users, 

It has come to our attention that selective Afrihost Fibre installations do not allow FreshPhone users to register SIP accounts as per usual, we enquired with them as to why this was occurring and they reverted with a possible solution for affected users to implement. 

This has proven to resolve any registration issues reported thus far and is quite simple to do, there it is: 

When you are setting up your SIP account on whichever device you may be using, simply add ":5060" at the end of the SIP-Server address, as seen here:

Sip-Username: 2787*******


Sip-Password: *************

Please let up know if this has helped you with your setup. 

Best Answer

VoIP thru ===> FreshPhone & Afrihost are looking up!

Zoiper software phone settings as per QR Code -- plus IP address

Account name :  FreshPHONE


Username:          27870123456                           ( not my real number)

Password:    *******************  (no idea as it is - Set by QR Code process

Outbound proxy:  was the same “HOST” above.

D-Link AC1200 Wi-Fi Gigabit Router settings:

I played with SIP ALG (under security)-switch back to the default “ON”

System seems to be working fine – caused plenty of frustration – Now to look forward to crystal clear voices at an affordable cost. 

(High light text was changed)

Many thanks to all concerned.


1 person has this question

Hi Oliver,

I hope you are well. Please can you delete the application and re-configure it without touching any backend settings. You need to have the free version of the application running in the background so it keeps the account registered once you close the app it kills the registration which is why you are not receiving any incoming calls. Please let me know if the issue is resolved after the re-configuration of the application. 

Thank you. 

HI Fresh

Thanks yeah, so I figured out that I leave the app open in the background it does receive incoming calls.

I didn't realise that was a limitation. Will see how the next couple months go and if I am happy, maybe I will upgrade to pro.

Thanks for the help.

Hi Oliver,

Thank you. 

Just wanted to say on Afrihost/Vumatel in zoiper I changed both the Server and Proxy to and its working fine now.

We with Afrihost.  Have a DLink modem. Registered & Rica with Fresh Phone.  Bought a Gigaset handpiece.. and my husband is trying to configure with no success.

Device status "Offline".

Where we try to add ":5060" for Afrihost it won't allow the ":" sign.  (On Gigaset  interface)

I've managed to use FreshPhone through Zapoid on my mobile, but we want to use the handset used for our home. 

If you're here because you have the same problem with 

- Registering

- Using Zoiper app on smartphone

- Using D-Link DIR825

- on Afrihost Fibre

Here is the solution that WORKS:

on the app:


Outbound proxy:

Leave SIP ENABLED under FIREWALL & DMZ SETTINGS on your router

DO NOT ENABLE 'PUSH PROXY' - this breaks the connection

We're going to have to live without Push notifications until I find a solution that works

Hi Marcel,

Have you tried the FreshPhone mobile app? I see you are using Zoiper, any reason for that? The app has push functionality as well as support for G729 now.

Because I'm using 2 Freshphone accounts & I don't think the mobile app can do that.

It might, but I did have problems with the app yesterday, it wouldn't let me register the new account, and then it wouldn't let me register the old account either.


My Fibre provider is AFRIHOST

If you try using PUSH PROXY on AFRIHOST wifi, it will NOT work.

The secret is to change your Wifi settings from DHCP to Static & change your DNS on your phone to anything else (Cloudflare e.g.

This solves the problem!

Thanks for the update


I have a Huawei B618 router on Afrihost fibre that I just cannot manage to get to connect and register on voip. The router was previously used on the RAIN network, but I have subsequently migrated to Afrihost fibre. While the SIM was in and it was used on RAIN the system registered perfectly and worked flawlessly. When the fibre installer installed the fibre line he reset the router and it lost all the voip settings. I have tried all the settings on the various forums and am out of ideas. Please help.


Hi there 

Please advise if SIP ALG is enabled or disabled 

As if you are using afrihost fibre with a vumatel backend sip alg needs to be enabled.

Please advise

From my test with one of the B Series Huawei modems, whichever one Cell C were handing out a few years ago, it would not do VOIP with a ethernet WAN connection. It only worked if the WAN was via a mobile connection. 

Login or Signup to post a comment