Start a new topic

Afrihost Fibre - FreshPhone Account Registration Failed - POSSIBLE FIX

Dear FreshPhone Users, 

It has come to our attention that selective Afrihost Fibre installations do not allow FreshPhone users to register SIP accounts as per usual, we enquired with them as to why this was occurring and they reverted with a possible solution for affected users to implement. 

This has proven to resolve any registration issues reported thus far and is quite simple to do, there it is: 

When you are setting up your SIP account on whichever device you may be using, simply add ":5060" at the end of the SIP-Server address, as seen here:

Sip-Username: 2787*******


Sip-Password: *************

Please let up know if this has helped you with your setup. 

Best Answer

VoIP thru ===> FreshPhone & Afrihost are looking up!

Zoiper software phone settings as per QR Code -- plus IP address

Account name :  FreshPHONE


Username:          27870123456                           ( not my real number)

Password:    *******************  (no idea as it is - Set by QR Code process

Outbound proxy:  was the same “HOST” above.

D-Link AC1200 Wi-Fi Gigabit Router settings:

I played with SIP ALG (under security)-switch back to the default “ON”

System seems to be working fine – caused plenty of frustration – Now to look forward to crystal clear voices at an affordable cost. 

(High light text was changed)

Many thanks to all concerned.


1 person has this question


Thanks for the reply.

I have yes (atleast on the older tplink) no change.

Hi Oliver

If you can make calls, but not receive on a connection, but you can on another, it points to bidirectional UDP traffic via port 5060 not being allowed to and from our server by your ISP. 

Your 3G ISP is allowing it, and this is why it works.

You have also tried multiple routers, DLINK are notoriously bad with VoIP, but TP Links are great.

Please try and turn off the Firewall, and try and turn it down to it's minimum and test again

I have a DLink DIR825 with Afrihost fibre. I also use a Grandstream HT802 which I plug my old landline into. It all works well. What I found is that I did not need to disable SIP ALG or SPI or anti spoofing as has been suggested in some Internet posts. My hardware is G1 and firmware is very 7. You must tell the Grandstream to use Tel URl=Phone

HI Freshman,

Thanks I did try turning the firewall off on the TP Link with no luck. I will try it at the end of the month when the fibre line is up and the new Dlink as well. I agree with you it is either an ISP or router issue though.

@Paul, thanks for the input, but I am not quite with you :) Could you please explain how I could correct this? Thanks

Oh. I see. I had so many issues getting my FreshPhone account to register. I could not make it work regardless of whether I used port 5060 or not. I even tried to substitute with its DNS resolved IP address of I was thus using combinations of:,, and

Most posts I saw about the DIR825 related to older firmware/hardware versions. I thus guessed that by virtue of its newer firmware/hardware that the issues would be resolved. I even tried to port forward 5060 (UDP), 5061 (SSL).

My one question would be can one use SSL (5061) instead of UDP (5060)? Would one need to set up an SSL Certificate for this?

Here is my Grandstream config pic - note this IP address and not the DNS name and the use of User-Phone:


And below is my DIR825 Firewall setup:


If you're here because you have the same problem with 

- Registering

- Using Zoiper app on smartphone

- Using D-Link DIR825

- on Afrihost Fibre

Here is the solution that WORKS:

on the app:


Outbound proxy:

Leave SIP ENABLED under FIREWALL & DMZ SETTINGS on your router

DO NOT ENABLE 'PUSH PROXY' - this breaks the connection

We're going to have to live without Push notifications until I find a solution that works

Hi Paul

5061 on our platform uses Transport layer Security ( TLS) It is not active on Sip1 only accepts UDP traffic on 5060

Nat Traversal on your Grandstream ATA should be set to Keep-Alive

Thanks did this (Nat Traversal on your Grandstream ATA should be set to Keep-Alive)

No TLS....well there goes that idea....

I was having the same issues initially with AfriHost and Cellphone data.

Could receive and make calls on cellphone data but could not receive or in my case make calls on AfriHost.

My system seems to be working and stable now...

Thank you to all concerned - I now have an active & working Fresh Phone app on my Smart phone via Afrihost - To recap looks it like there was an issue with the DNS on the outbound proxy and the URL required the port no of 5060  THe SIP ALG was not an issue.

I seem to not be getting incoming calls now? Not sure if it is related?

Incoming always worked for me.

Is it working for you guys with Afrihost/Vuma Fibre?


Hi Oliver, 

I see your phone is offline, this is why you are not able to receive any inbound. Can you try rebooting the SIP device?

Hi Fresh Man,

So I restarted my iPhone. It does ring when I have my phone just laying there (lock screen) BUT when I open the app and have it connected it does ring.

So must be some setting. Could you advise?

Don't really want the battery to drain excessively though...I did see something related to that.


Hi Marcel,

Have you tried the FreshPhone mobile app? I see you are using Zoiper, any reason for that? The app has push functionality as well as support for G729 now.

Login or Signup to post a comment