Start a new topic
Answered

Afrihost Fibre - FreshPhone Account Registration Failed - POSSIBLE FIX

Dear FreshPhone Users, 


It has come to our attention that selective Afrihost Fibre installations do not allow FreshPhone users to register SIP accounts as per usual, we enquired with them as to why this was occurring and they reverted with a possible solution for affected users to implement. 


This has proven to resolve any registration issues reported thus far and is quite simple to do, there it is: 


When you are setting up your SIP account on whichever device you may be using, simply add ":5060" at the end of the SIP-Server address, as seen here:


Sip-Username: 2787*******

Sip-Server: sip1.freshphone.co.za:5060

Sip-Password: *************


Please let up know if this has helped you with your setup. 


Best Answer

VoIP thru ===> FreshPhone & Afrihost are looking up!


Zoiper software phone settings as per QR Code -- plus IP address


Account name :  FreshPHONE

HOST:             sip1.freshphone.co.za:5060

Username:          27870123456                           ( not my real number)

Password:    *******************  (no idea as it is - Set by QR Code process

Outbound proxy:    41.221.5.251  was the same “HOST” above.


D-Link AC1200 Wi-Fi Gigabit Router settings:

I played with SIP ALG (under security)-switch back to the default “ON”


System seems to be working fine – caused plenty of frustration – Now to look forward to crystal clear voices at an affordable cost. 

(High light text was changed)


Many thanks to all concerned.


Ed


1 person has this question

Hi there. This probably should not go here but it is linked to Afrihost.

We have had an excellent system working well. Vumatel installed the fibre. Afrihost is our ISP.

We ported to FreshPhone on 11 Oct. All was well. My deaf mom in law commented on the clarity of the phone calls to the US and Australia and the cheap call rate.

On Friday 10 November 2107 at 10am I was working when a website I opened came up with a DNS resolution error. I reloaded - frequently. It did not help. We have had extremely slow Internet access with DNS resolution errors continually. Reverse DNS is OK and responds. Forward DNS never works and with nslookup and traceroute gives timeouts. I have been unable to connect my GrandStream HT802 to sip1.freshphone.co.za and it also says not connected as does the tms.freshphone.co.za portal.


I have been on the phone to Vuamtel and Afrihost for a combination of 40 minutes. Neither can solve the issue. I cancelled my Afrihost package (10M up/10M down unshaped/uncapped). They convinced me to rejoin which I did. But my condition was 12 months free Internet access for the inconvenience.


I have reset the router (DLink DIR825) to factory defaults. This has not helped. I cannot solve this. I cannot get either Vuamtel or Afrihost to help me.


I am completely out of ideas and cannot work as I have no Internet access or phone.


I have set up DNSservers in DIR825 to be 8.8.8.8 and 8.8.4.4 from Afrihosts 169.1.1.2 and 169.1.1.3


When I use Speedtest.net to test the line I cannot load it. MyBroadband Speedtest gives me a latency to CT or JNBof 19ms with 7.9M up and down.


I do not have a 4G modem to plug into WAN port to rule out DIR825 failure.


The only thing I can think of is that Afrihost has changed DNS settings or that they have changed their IP6 implementation as I have seen that before or that I am being subjected to a DDoS.


Does anyone have any suggestions to try?


Thanks in advance and sorry if I posted in the wrong forum.

Just wanted to say on Afrihost/Vumatel in zoiper I changed both the Server and Proxy to sip1.freshphone.co.za:5060 and its working fine now.

Is there ANY one out there that has Afrihost as their ISP and can use VoIP (Freshphone)?

I use Afrihost  as an ISP and their "D-Link AC1200 Wi-Fi Gigabit Router" with no luck.. -

I have added 5060 (sip1.freshphone.co.za:5060) - set SIP ALG off, Audio codec to iLBC30 on


I have two profiles - One set up manually and the other via the QR CODE. The diff is User name and password - I manually use my email and pwd -- QR code use the phone no an (a hidden) pwd.


The smart phone all Zoiper fails to register - sometimes complains about DNS time out(503) & 

Request Timeout (408)

 

Hi Edward, Please try:


I have added 5060 (sip1.freshphone.co.za:5060) - set SIP ALG off, Audio codec to iLBC30 on


With SIP ALG turned on, I saw someone was able to get it to work that way before. Please let me know if this does not work.

Hi Fresh Man, - I did as you suggested and turned on the ALG on the router.

Note I have also set the outbound proxy to 41.221.5.251  as "Brian" suggested! - (he has posted a full history of his attempts to connect the VoIP) 

The profile showed a green tick - It deregistered on trying to make a phone call.


How do i force the smart phone to re-register & not wait the 60 minutes?

Hi Fresh Man,  Sill no luck - ALG On and Off but with TCPIP addr for outbound proxy.


Question If i buy/use the physical hand set am I also going to have this sort of trouble! 

Hopefully it will be better


I believe you will have the same issue. Let's try using the IP instead of the hostname, also please see correspondence below from a Director at Afrihost:



SHORT VERSION:
        Change the SIP client name from "sip1.freshphone.co.za" to "sip1.freshphone.co.za:5060"

DETAIL:
I have replicated this problem using the DLINK router and zoiper (SIP client) on android.  The problem does NOT appear on the DLINK router and media5 (SIP client) on android.

The error you reported is the text I see on Zoiper on android (503).  The problem was visible behind the DLINK, and not from the network the DLINK is plugged into.  It is not possible to use the DLINK without "SIP ALG" enabled, which I believe is default.  The connection to sip1.freshphone.co.za does not attempt to pass through the router - for reasons I cannot establish.

The problem does NOT appear for me when changing the host name from sip1.freshphone.co.za to the IP address 41.221.5.251

The problem does NOT appear for me when changing the host name from "sip1.freshphone.co.za" to "sip1.freshphone.co.za:5060"

Taken together, this means that the DLINK SIP algorithm is unable to handle the host name unless it has the port number appended.

My freshphone (zoiper) was still working when I was on afrihost adsl. Now swopped to fibre and I can't dial out on wifi.

Oliver, are you using Vumatel and Afrihost?


We seem to have a lot of cases of people moving from DSL or LTE to Afrihost Fibre and not being able to use Freshphone.


Have you tried the above suggestion from Afrihost?

Answer

VoIP thru ===> FreshPhone & Afrihost are looking up!


Zoiper software phone settings as per QR Code -- plus IP address


Account name :  FreshPHONE

HOST:             sip1.freshphone.co.za:5060

Username:          27870123456                           ( not my real number)

Password:    *******************  (no idea as it is - Set by QR Code process

Outbound proxy:    41.221.5.251  was the same “HOST” above.


D-Link AC1200 Wi-Fi Gigabit Router settings:

I played with SIP ALG (under security)-switch back to the default “ON”


System seems to be working fine – caused plenty of frustration – Now to look forward to crystal clear voices at an affordable cost. 

(High light text was changed)


Many thanks to all concerned.


Ed

Thanks, Edward, hope things go smoothly from here!

HI Freshman and Ed,

I had tried all previous solutions, but didn't realise that the sip1. etc. had to stay under incoming and it it ONLY the outgoing that needs to change to the IP. So basically as per ED's post above!! THANKS!!!

I can confirm it is now working on Afrihost, with Vuma, with the Dlink 825 router. ALG set to ON.

Awesome!

Just signed up with Freshphone and still on Afrihost ADSL, but swopping to fibre. Have tried on my old TP link router currently being used, and on the new Dlink DIR825 provided by afrihost, and so far I can't get any incoming calls either.

I can dial out on wifi. On 3G I can dial out and receive calls.

Hi Oliver


Have you disabled a function called SIP ALG on your DLINK? Normally under Firewall tab

Login or Signup to post a comment