Start a new topic

Registration Issue

Hi. I have been using Freshphone via Zoiper for Android (Samsung Galaxy Note3) for a few weeks on a 4Mbps ADSL line. The service was trouble-free. Yesterday I moved to a Fibre FTTH connection (50up/50down) and my Voiper would not register or connect.  I have tried re-installing, and tried every combination of I can think of to configure the Voiper settings, but to no avail. I have also tried the Media5 softphone, but still also with connection/registration issues.

The fields required in the soft phone settings are provided by on my Freshphone dashboard, but the names of the fields differ slightly from the names of the corresponding fields in the softphones, so I may be missing a trick there.

My router is a new D-Link AC1200 Wifi Gigabit router Dual band 11AC for 802.11ac wireless (for the tech boffins)

Can anyone confirm what Freshphone data populates what Zoiper or Medi5 phone setting screens?

Kind regards,,,


1 person has this question

Hi Brian, 

We recommend that you contact your Fibre ISP, as you have stated that the service worked up until you switched your connectivity provider.  

they must ensure you that all traffic is allowed, to and from our servers. 

The communication protocol must be set to work over UDP. 

Hi there. I have contacted my Fibre ISP (Afrihost) who have confirmed that there are no blocked protocols on my my account, and that UDP is enabled.

They have suggested that you ad their IP range to your system. Their range is 169.1.  

Can you please check this out?


This is taking too long.

Please advise how I cancel my account and get my credit balance back. 

I have a business to run and I can't run around between service providers. I must find a provider that at least has a more responsive support team.

Hi Brian, 

We will advise our accounts department to get in touch with you regarding the cancellation of your account. 

The team here at FreshPhone would like to take this opportunity to reiterate and remind users, that, FreshPhone is designed as a "Free Home-use" or "Residential" service, in order for this service to remain such a service, we have created a community-based forum where we urge our residential customers to communicate with and assist each other in a spirit of goodwill, while our team at FreshPhone will add or elaborate on any posts where the community has not yet helped out or resolved a certain aspect of questions posted.

We welcome anyone to make use of our service but would urge business customers to revert to our parent company in order to make use and take advantage of their Premium Business Telecoms Solutions. 



I have run a trace on the freshphone sip1 address and seem to have found a problem in the freshphone IP range (41.221).  This may be causing problems with other customers as well.  

Kind regards



Tracing route to []

over a maximum of 30 hops:


  1 1 ms 1 ms 1 ms dlinkrouter []

  2 4 ms 2 ms 2 ms []

  3 3 ms 2 ms 3 ms []

  4 3 ms 2 ms 2 ms []

  5 4 ms 3 ms 3 ms [

  6 21 ms 21 ms 21 ms

  7 22 ms 20 ms 21 ms

  8 * * * Request timed out.

  9 21 ms 20 ms 20 ms []


Trace complete.



Hi Brian, 

This looks like a fire wall block setting, can your ISP confirm that you are able to reach our servers? 

You can try pinging it from your PC to test this yourself. 

Hi Brian, 

Thank you for your patience, and cooperation thus far, this forum update simply serves to announce to other users that we are indeed working on possible resolutions with you and your connectivity provider to see if we can facilitate or assist you with the errors you are encountering. 

You need not reply to this, we will once resolved, update this forum again so other users experiencing a similar scenario can make use of the information. 

Hi Brian,

We are so happy to see that you were able to get your FreshPhone account to work with your new Afrihost fibre installation, We received your very thorough report via our parent company Euphoria Telecom, detailing the trials and successes you managed to achieve, thank you for all of your efforts and patience during this process, we are sure the findings will be an invaluable resource to other users that might be experiencing the same issues, we have condensed the matter below.


Brian has a FreshPhone SIP account and uses it on this Mobile phone when we conducted a test using only mobile data (Not Wifi) the registrations worked perfectly, hence the conclusion that the ISP he uses for his Wifi connection may be blocking some sort of traffic in- or outbound.


Here is what he said:

"Since yesterday morning, my general connectivity was problematic, and any browsing was difficult. It came to a head this morning when I needed to do some online banking and I could not connect to my bank via the router. So, this afternoon reset the router to factory defaults and everything is working fine again. (Phew..!) … except for my sip phone."

Brian then compiled a further short event based summary below: 

"I am having problems with my Zoiper phone. The problem seems to be somewhere in my router, or it’s in my ISP, or Sip provider. Before we start let me give you some background. I installed Zoiper on my phone, and signed up to a SIP provider, and was able to operate well via my ADSL Wifi connection. I then upgraded to Fibre (50up/50down) and had overall greatly improved connectivity, except my SIP phone no longer worked. 

I am using a Samsung Note3 (SM-Noo5) android device running android version 5.0. My router is a brand new D-Link AC1200 Wifi Gigabit router. On standard/default settings. My Zoiper phone connection works if my phone is off of my wifi. Ie it works on 3g/4g, but will not register to my Sip provider via wifi. I have set up Zoiper on my laptop (connected by wifi to router), and it will not connect to the sip provider. The message I get is SIP 503 – DNS Timeout.  I have run a TRACERT from my laptop on the SIP1 address, and this is the result that I got. 

Tracing route to [] over a maximum of 30 hops:

 1 1 ms 1 ms 1 ms dlinkrouter []

2 4 ms 2 ms 2 ms []

  3 3 ms 2 ms 3 ms []

  4 3 ms 2 ms 2 ms []

  5 4 ms 3 ms 3 ms []

  6 21 ms 21 ms 21 ms

  7 22 ms 20 ms 21 ms

  8 * * * Request timed out.

  9 21 ms 20 ms 20 ms []

 Trace complete.

A specialist from the SIP provider has checked my router settings quite thoroughly. (over 90 minutes using Teamviewer). "

Upon a recommendation to test a connection directly to the ONT here are Brians findings; 

"Tried connecting directly to the ONT (port 1) and had no success. 

  On the Zoiper connection on my laptop, I change to 

  And it worked. I dialled from my laptop (on wifi) to my cell and got a connection. 

  I then went to my cell and put the same address in the Host field.., but no success. Then I went to optional settings on Zoiper, and changed the outbound proxy to and, hey presto! it registered.  So it looks like all is working. 

Thanks for your patience guys.., will keep my FreshPhone :) "


Thanks again Brian from all of us at the FreshPhone team.

Similar ping and tracert results as Brian

Hi Paul, 

You can either go with something like a Yealink DECT phone or a Grandstream ATA adapter if you wish to re-use old hardware. It's totally up to you, they ultimately function the same way, you will be able to make and receive calls.

My GrandStream HT802 and old phone work OK. Call quality seemed better than the Telkom line.

Have not tried an overseas call yet.

And the latency is good too:


Hi Paul, which router are you using? I see a very very long email thread between our sister company and another user with a D-Link DIR-825 router. After a lot of backward and forward I see he just replaced with a mikrotik that Afrihost provisioned and he says everything is working 100%

You have tried to put the :5060 at the end of the registeration address? IE: 

Im not sure I may have seen you tried on another thread.

Hi there. I have exactly the same problem. AfriHost fibre 10Mb up 10Mb down. Huwawei fibre modem with DLink DIR825 Wifi router. My Android based Redmi Note 2 has a built in SIP/Internet phone service. I have also installed Zoiper and have a FreshPhone account.

All perfect on both AfriHost MTN and Vodacom mobile networks. Zoiper and built in Android SIP caller work on fibre.

Yes have tried both and

and and

No luck

Login or Signup to post a comment