Liquid error: undefined method `name' for nil:NilClass
Start a new topic
Solved

Grandstream HT801 no audio during calls

Hi,

I am able to make and receive calls, but in neither case can me or the other person hear each other after the call connects.


My router config does not contain any SIP blocking settings, previously i could phone without issues using the FreshPhone app on my cell phone and the wifi.


Please help as I have already initiated my porting request yesterday.


I have configured my GrandStream using the video on this forum as well as making the changes suggested by you guys in my previous post.


Thank you!


If G729 is the only codec enabled on the phone and SIP ALG is disabled on the router, it could mean that the level of your firewall is too high.


Please try dropping the security level of your firewall.

Not sure I understand, my router config has no firewall settings. Do you mean inside the Grandstream config?

I have done some digging, by running a SIP ALG detector on my PC it returned with:


##################################################################
#     Test Results:
###   - SIP UDP ALG: TRUE
###   - SIP TCP ALG: FALSE
IT IS RECOMMENDED TO DISABLE SIP ALG IN ROUTER SETTINGS !!!
##################################################################


However, I cannot find a setting in my router config application to change that.

If I am unable to turn it off in my router would using port 5062 be an option as I read that SIP ALG normally only affects port 5060?


You can try changing the local SIP port to 5062.


Please also trying changing the transport protocol TCP and advise if the same error occurs.

I tried just changing to TCP and now i have audio !

Thanks for all the help and patience.


For reference I used the sip-alg-detector from the ringlogix website to run the test which gave the output above.


Should i still try UPD with port 5062? will it be a better option than 5060 on TCP?

Perfect, thanks for the update and the tip.


I would recommend trying to use port 5062 and running the transport protocol over UDP.

Hi,

Just to close the loop for other that might find this thread in the future.


If you can make and receive calls but have no audio:

  1. Check your router config for a "SIP ALG" setting and ensure it is DISABLED.
  2. If like myself your router does not have such a setting, run the "sip-alg-detector" app I mention above.
  3. If the output says that SIP ALG is enabled, then you will have to bypass the 5060 port on UDP in the GrandStream settings by using port 5062 instead.
  4. Or you could stay on port 5060 and use TCP protocol, however the UPD option is preferred

I hope this helps someone else.

Thanks for the feedback.


This information would definitely be useful to other FreshPhone users as well.

Login or Signup to post a comment