Start a new topic
Solved

No Incoming Calls Snom 300

Hi , I have setup a snom 300 phone on a D-Link 2750u router, I've followed the instruction in the forum for that model, ensured that RTP encryption is off and support broken registrar is on. My account is 278709411819.


From what I can gather after multiple attempts at resetting phone and redoing setup, after initial setup phone works, can relieve and make calls. However wifi ceases having internet connectivity, while Ethernet internet connectivity for pc still works.


Resetting router fixes wifi connectivity issue, however after this can only make outgoing calls from phone, when try to make incoming call either does not go through, I hear a sound like a modem or get told the subscriber is unavailable.


I've tested my account with Zoiper and it works fine, can make and receive calls.


So it must be an issue with phone or router. But I did notice that this problem also started after I requested my Telkom number be ported, so not sure if that's related. 


I'm also unsure if switching router on and off causes issues, notice the phones IP address does change after doing this a few times. If I have to reconfigure everything , every-time I reset router, or reset router everytime I want wifi to work, that's untenable.


Please can you assist.


PS: As of right now, everything is working correctly, but I'm not sure howlong that will last or what will happen if have to turn on and off router again in future.

Untitled.jpg
(168 KB)

Actually stopped working again, soon after posting this. Issue is still persistent.

Hi Emil,


Please follow the steps in the link below to disable SIP ALG on your router. 


https://success.ringcentral.com/articles/RC_Knowledge_Article/How-to-disable-Sip-ALG-on-a-D-link-Router


Thank you. 

I am having the same problem - SIP ALG disabled - still not working.  My situation is a 100% match to this except the router is a Huawei.


Worked until port performed.  Considering changing to SwitchTel.


So with me , it just started working normally about 24 hours after I submitted this issue, without changing SIP ALG settings or doing anything. I subsequently did disable SIP ALG and it's been working fine so far.

Hi Heinrich,


I hope you are well. On the Huawei LTE routers there should be two settings disabled SIP ALG and the routers onboard firewall. Please also try pinging our host address "sip.freshphone.co.za" from your PC, if there is no response please advise so we can take the next step. 


Thank you. 

Hi,


I have since this logged a ticket - please refer to that - https://help.freshphone.co.za/helpdesk/tickets/4385


I have connected the phone to two different networks and had the same problem.


There must be other settings which has not been identified which resolved this when I copied the one line's settings to the other.


I am waiting for final feedback from Fresh IT on that ticket.


Thanks

H

Hi Heinrich,


There are settings on the snom device that could be causing this issue. The first will be  enabling "Support broken Registrar", it can be found under the SIP menu on the identity/account you are using.  In the second picture it shows the RTP menu and both "Symmetrical RTP" and "RTP Encryption" need to be turned off. Please edit these settings and test. 






Thank you. 


Login or Signup to post a comment