Start a new topic
Solved

Fanville g100s gateway Sip Registration failure

Hi I'm running a fanville g100s gateway running on fumes fibre through afrihost. My VOIP keeps disconnecting , wheni log on to the gateway I notice SIP registration failure. I can ping sip1freshphone.co.za and do a traceroute, however still no luck My router is doing Dir 816. SIP ALP etc all disabled. Any assistance will be appreciated Thanks Vick

Hi Vickesh,


We have issues with this type of set up before, please see below an extract from a conversation I had with a high level system engineer at Afrihost. I have had a few clients try this method with success.



"SHORT VERSION:
        Change the SIP client name from "sip1.freshphone.co.za" to "sip1.freshphone.co.za:5060"


DETAIL:
I have replicated this problem using the DLINK router and zoiper (SIP client) on android.  The problem does NOT appear on the DLINK router and media5 (SIP client) on android.

The error you reported is the text I see on Zoiper on android (503).  The problem was visible behind the DLINK, and not from the network the DLINK is plugged into.  It is not possible to use the DLINK without "SIP ALG" enabled, which I believe is default.  The connection to sip1.freshphone.co.za does not attempt to pass through the router - for reasons I cannot establish.

The problem does NOT appear for me when changing the host name from sip1.freshphone.co.za to the IP address 41.221.5.251

The problem does NOT appear for me when changing the host name from "sip1.freshphone.co.za" to "sip1.freshphone.co.za:5060"

Taken together, this means that the DLINK SIP algorithm is unable to handle the host name unless it has the port number appended."


Please give it a go and see if it works better for you.



1 person likes this
Thanks ! Late yesterday playing around like you correctly mentioned i realised i need SIP ALG enabled for it to register ! Is this issue related to Dlink routers only ?

I believe so, since you are using a DLINK and on the afrihost network, I think you are the perfect candidate for this solution, please let me know if it works or doesnt work for you.


Thanks

Just to add.. so if I f sip1.freshphone.co.za:5060 i should able to turn off SIP ALG on my router and it should register ?

It would seem, from Afrihosts reply that the router requires SIP ALG to be enabled, but you also need to append the register server with the port number :5060

So I tested , regardless of whether I choose sip1.freshphone.co.za or sip1.freshphone.co.za:5060 or the IP address, SIP ALG has to be enabled in all 3 scenarios for the SIP to register.
Out of curiosity do other ISP's have the same issue ?

I guess that its a requirement on DLINK, maybe they did not adhere to RFC standards, Im not sure. 


With regards to other ISP's, I think some do yes, I know we have huge issues with CellC. I think this is more related to the router than the ISP, I seem to remember a client changing their DLINK to another router and using afrihost fine. 


Safe to assume the issue is resolved?

Yes, thanks for your help Fresh Man !

Awesome, its a pleasure.

Login or Signup to post a comment