Start a new topic

Unable to purchase airtime

I am struggling to buy airtime since Tuesday. I was able to topup with R100, but needed more. I get the same error message that the screen was unable to load after I have typed in my card details.

 

I have send mails to billing@freshphone.co.za and freshphone@euphoria.co.za, but didn't get any assistance. The mail to freshpone@euphoria.co.za was returned as undeliverable!


Please assist. I need airtime urgently.




1 person has this question

Please could you screen shot the error when it occurs, it will assist us in identifying at which point the issue is occurring.

Hi attached
image001.jpg
(4.14 KB)

Thank you, I will have development look into this.

Thanks Fresh Man. Is there any other way to buy airtime? I am probably going to run out today.

Hi, I see that my RICA status changed. Why is that? I have uploaded my ID again....

I'm unable to buy airtime. Every time after clicking on Top Up and then on Pay Now With Credit Card and then OK when getting the message: 

You will now be navigated to the Payment Gateway Page. This page is a secure page allowing you to enter your credit card details. If there is an error on the page, you can contact us to confirm if the payment has been completed. The actual credit card transaction can take some time, so please be patient when submitting.

Click OK to proceed.

 Then I always get:

There seems to have been a problem please reload the page. If the problem persists please notify us with the problem and we will resolve it as quickly as possible. Sorry for the inconvenience.

 as per the attached screenshot.


I've tried with different browsers.

I today experienced the same problem. How did you resolve it?

Hi I also have the same problem. Please advise

I'm also experiencing the same problem .and its frustrating .


 

Same issue here

Has anybodies problem been solved? I still can't buy airtime. Any other VOIP suggestions?

Hi all, my issue was resolved with an update on my account details by freshphone, screenshot attached

Hi Gawie, I unfortunately cant read the details of your screenshot. I went to my account details and just made an update but I am not entering any bank account details. 

Hi all, my issue has also been resolved now. After reading Gawie's screenshot above, I checked my account details. My email addresses on my account and billing details matched but I still couldn't make a payment. Then I noticed my phone number on the billing details was missing the initial '0'. Once I put this in, my payment went through.

Login or Signup to post a comment