Start a new topic
Solved

Granstream HT801 unregisters frequently

Hi, 


I have a Granstream HT801 connected via LAN cable to my Mikrotik Hap Lite AP, and have a 4mb Fibre connection.


Every morning I wake up and the HT801 shows that is not registered. I try to reboot, turn the account to not active and them active again but nothing gets it to re-register. The only way I can get it to register is to do a VoIP data reset on the UI or by pressing the reset button on the unit, and then re-entering the SIP details from scratch. I have tried extending the registration expiration time and setting a re-register before expiration time, but this has not helped. On a few occasions, it has managed to go a few days (2 or 3) without having this problem.


Does anyone have a similar issue or know why this is happening?


Hi Trishen


There are 2 fixes to try here, each contradicts the other. So please test both as it depends on how your router is handling the traffic


Option 1


NAT Traversal has settings: No, Keep-alive, STUN and UPnP.  Both units must be set to "keep-alive".



Option 2


NAT Traversal must be disabled on the ATA Adaptor. It causes similar problems to SIP ALG

Thanks, I will test this and give feedback.

Hi Trishen


Your account seems to stay online now, or am I just by chance looking when it is online?

Hi,


Yes, I think it is working now. I implemented the suggested change on Saturday morning, and it hasn't disconnected yet, so it definitely looks like its working. 


Thanks so much for your help!

Hi Trishen


That is great news. 

Hi Freshman - just got the ht801 and cant get it to register, did use zoiper first and that worked, must I unregester that first. Is there a complete list to set up the grandstream 801 ?

Just an update on my issue. The keep alive didn't help, it disconnected after about 4 days. I did find a solution that worked thought. Give the ata highest priority in the QOS of the router. Register expiration = 30 SIP Registration Failure Retry Wait Time = 120 Enable SIP OPTIONS Keep Alive: = no Haven't had a disconnect in about 2 weeks.
Hi Len, Try this: On the basic settings tab reset both the ISP and VoIP date. The ata will reboot. On the advanced setting tab, the default upgrade and config path are wrong. Get the new path from the grandstream website. I can't remember what it is off hand. Reboot the ata and let it do the software upgrade. When setting up the ata the only tab that needs configuring in the fxs port tab. Set the account to active, the primary server, the authenticate username and the authenticate password. That's all and it should connect. Hope that help T

Hi Trishen - will try ( Its so good to get feedback )

it is set to http and fm.grandstream.com/gs is this wrong

firmware.grandstream.com is the only other I found

Yeh, I think it's firmware.grandstream.com

I just checked the website and that's the same one I found.


The config server doesn't matter because you set your own config on the fxs port tab.

This has done a change to the firmware. plugged in all my stuff id etc & Password

reboot must I uninstall zoiper first on android?

Did it connect?


You don't have to uninstall Zopier. You can have multiple devices connected to the same sip account.

While you can have the same SIP account on multiple devices, it will ring on either of them, not simultaneously. IE you could be out and expect a call to ring on Zoiper but it will be ringing on the Granstream device, there's no way to have them work simultaneously. Therefore having the same SIP account on multiple devices isn't recommended.

Login or Signup to post a comment