Liquid error: undefined method `name' for nil:NilClass
Start a new topic

how to setup Cisco SPA 112 series Analogue Telephone

 Could some please provide me with all the information  I require to set up the above device.

Many thanks  William

1 person has this question

I double checked and that is the IP address that I had entered. I have been following the steps very closely.

About my T28P, it will not register now. That has always worked. Did you change something on my account? I tried updating the phones password and that didn't work.

Hi Joseph,

I hope you are well. I see that your account is registered to a Yealink T28P, please confirm that the phone is working. 

Thank you. 

Yes the T28P is connected again thank you! But the Cisco ATA still isn't. Any idea's?

Still not working

Hi Joseph

The T46 that you have connected now is showing an extremely high latency, ie bad internet connection. I am surprised that it is even registered

So I have removed the account from the other phones. It should only be setup on the Cisco SPA 112 now but it still doesn't want to register. 

I understand only incoming calls will route to the first phone registered on your system. But that shouldn't be the issue here. 

Hi Joseph

I would like to check if we are maybe blocking your IP due to incorrect credentials being used at some point. Please coonect a PC to teh same internet connection that the 112 connects and go to google and type Whats my IP

Send through IP to us and we will double check the Blacklist

My current IP is

Hi Joseph,

I hope you are well. We are currently not blocking your public IP address. Please try and ping our PBX address ( from your PC connected to the same internet connection. If you do get a reply that means either the Cisco device is not configured correctly or there are protocols on the internet router which are blocking the VoIP traffic. Please follow the steps to setup the device correctly which will be located on the first page of this forum post. Also, check that SIP ALG is disabled on your internet router and your firewall setting are set to low. If the troubleshooting does not solve the issue, please provide the make and model of your internet router and we will take it from there. 

Thank you.   

I can reach the server fine. Other phones like my Yealink are able to register just fine at the same location. I recently changed all my network equipment to Ubiquiti and I have checked the SIP-ALG and thats not the issue. 

I have checked the settings with the images on this discussion 15 different times over 5 months. Factory reset it many times. I don't believe the Cisco SPA 112 is compatible with your service. 

Hi Joseph

If those steps are followed and the device is in proper working order, it will work with any SIP service. here is a link to a post that got his SPA 112 working

The only tip in that posting was to leave the device unplugged for three hours. So I left mine unplugged for four hours. Double checked the SIP setting in the Ubiquiti controller and its disabled by default so again SIP-ALG is not the issue here.

Long shot but what DNS do you recommend? 

Hi Joseph

A good bet is always Googles DNS

Login or Signup to post a comment