Start a new topic
Answered

Afrihost Fibre - FreshPhone Account Registration Failed - POSSIBLE FIX

Dear FreshPhone Users, 


It has come to our attention that selective Afrihost Fibre installations do not allow FreshPhone users to register SIP accounts as per usual, we enquired with them as to why this was occurring and they reverted with a possible solution for affected users to implement. 


This has proven to resolve any registration issues reported thus far and is quite simple to do, there it is: 


When you are setting up your SIP account on whichever device you may be using, simply add ":5060" at the end of the SIP-Server address, as seen here:


Sip-Username: 2787*******

Sip-Server: sip1.freshphone.co.za:5060

Sip-Password: *************


Please let up know if this has helped you with your setup. 


Best Answer

VoIP thru ===> FreshPhone & Afrihost are looking up!


Zoiper software phone settings as per QR Code -- plus IP address


Account name :  FreshPHONE

HOST:             sip1.freshphone.co.za:5060

Username:          27870123456                           ( not my real number)

Password:    *******************  (no idea as it is - Set by QR Code process

Outbound proxy:    41.221.5.251  was the same “HOST” above.


D-Link AC1200 Wi-Fi Gigabit Router settings:

I played with SIP ALG (under security)-switch back to the default “ON”


System seems to be working fine – caused plenty of frustration – Now to look forward to crystal clear voices at an affordable cost. 

(High light text was changed)


Many thanks to all concerned.


Ed


1 person has this question

Hi Fresh Man, - I did as you suggested and turned on the ALG on the router.

Note I have also set the outbound proxy to 41.221.5.251  as "Brian" suggested! - (he has posted a full history of his attempts to connect the VoIP) 

The profile showed a green tick - It deregistered on trying to make a phone call.


How do i force the smart phone to re-register & not wait the 60 minutes?

Hi Fresh Man,  Sill no luck - ALG On and Off but with TCPIP addr for outbound proxy.


Question If i buy/use the physical hand set am I also going to have this sort of trouble! 

Hopefully it will be better


I believe you will have the same issue. Let's try using the IP instead of the hostname, also please see correspondence below from a Director at Afrihost:



SHORT VERSION:
        Change the SIP client name from "sip1.freshphone.co.za" to "sip1.freshphone.co.za:5060"

DETAIL:
I have replicated this problem using the DLINK router and zoiper (SIP client) on android.  The problem does NOT appear on the DLINK router and media5 (SIP client) on android.

The error you reported is the text I see on Zoiper on android (503).  The problem was visible behind the DLINK, and not from the network the DLINK is plugged into.  It is not possible to use the DLINK without "SIP ALG" enabled, which I believe is default.  The connection to sip1.freshphone.co.za does not attempt to pass through the router - for reasons I cannot establish.

The problem does NOT appear for me when changing the host name from sip1.freshphone.co.za to the IP address 41.221.5.251

The problem does NOT appear for me when changing the host name from "sip1.freshphone.co.za" to "sip1.freshphone.co.za:5060"

Taken together, this means that the DLINK SIP algorithm is unable to handle the host name unless it has the port number appended.

My freshphone (zoiper) was still working when I was on afrihost adsl. Now swopped to fibre and I can't dial out on wifi.

Oliver, are you using Vumatel and Afrihost?


We seem to have a lot of cases of people moving from DSL or LTE to Afrihost Fibre and not being able to use Freshphone.


Have you tried the above suggestion from Afrihost?

Answer

VoIP thru ===> FreshPhone & Afrihost are looking up!


Zoiper software phone settings as per QR Code -- plus IP address


Account name :  FreshPHONE

HOST:             sip1.freshphone.co.za:5060

Username:          27870123456                           ( not my real number)

Password:    *******************  (no idea as it is - Set by QR Code process

Outbound proxy:    41.221.5.251  was the same “HOST” above.


D-Link AC1200 Wi-Fi Gigabit Router settings:

I played with SIP ALG (under security)-switch back to the default “ON”


System seems to be working fine – caused plenty of frustration – Now to look forward to crystal clear voices at an affordable cost. 

(High light text was changed)


Many thanks to all concerned.


Ed

Thanks, Edward, hope things go smoothly from here!

HI Freshman and Ed,

I had tried all previous solutions, but didn't realise that the sip1. etc. had to stay under incoming and it it ONLY the outgoing that needs to change to the IP. So basically as per ED's post above!! THANKS!!!

I can confirm it is now working on Afrihost, with Vuma, with the Dlink 825 router. ALG set to ON.

Awesome!

Thank you to all concerned - I now have an active & working Fresh Phone app on my Smart phone via Afrihost - To recap looks it like there was an issue with the DNS on the outbound proxy and the URL required the port no of 5060  THe SIP ALG was not an issue.

I seem to not be getting incoming calls now? Not sure if it is related?

Incoming always worked for me.

Is it working for you guys with Afrihost/Vuma Fibre?

Thanks

Hi Oliver, 


I see your phone is offline, this is why you are not able to receive any inbound. Can you try rebooting the SIP device?

Hi Fresh Man,


So I restarted my iPhone. It does ring when I have my phone just laying there (lock screen) BUT when I open the app and have it connected it does ring.

So must be some setting. Could you advise?

Don't really want the battery to drain excessively though...I did see something related to that.

Thanks

Hi Oliver,


I think this is a limitation of Zoiper (free version) I believe that Zoiper Pro and Groundwire have a keep alive/push notification service which would allow the app to wake when a call comes in. I have not tested Zoiper pro but I have tested Groundwire and it works quite well.



Ahh okay.

It's odd as it was definitely working before.

Login or Signup to post a comment