Start a new topic
Solved

Broken voice on certain numbers only

I'm having a weird problem with my freshphone account. About half the numbers I dial are completely unusable when someone answers the phone. The line goes garbled and you can't understand a word on the other end. I use G.729 protocol and the licences and everything are sorted and all is working. 


For some reason it doesn't do this with all phone numbers. Only a handful. Any ideas? My line latency reports as 5-10ms and I've turned off the weird SIP nonsense that is supposed to be a troublemaker on the router to no avail.


Noted

Thank you for changing the codec. Note that I use this number on Linux Mint and Windows desktop computers, with the Zoiper program.

Hi Aidan


Zoiper Premium with g729 is R218 on iOS

Hi Aidan


Very strange that your connectivity to our servers only suffers when calling landlines. Maybe it has to do with how its been passed onto to the landline provider, not sure. I can't recreate the issue.


I have disabled the stronger codec on your account( OPUS) and left GSM and g729( perfect call quality but you need a device or app that has this premium codec) 


Do a test call if you don't mind and see how the lesser bandwidth codec fairs.

Hi Fresh Man


I have not yet bought Zoiper Pro (which will cost R650 I believe). Today, I had two calls to land lines that had bad jitter - 0219121800 and 0216722500, which I called at 11:09 and 11:12 respectively, lasting 9s and 4s respectively.


I then used an alternate number to call 0216722500 at 11:18 - I used my MWeb Talk number. Behold! The line had no jitter. (This indicates which provider I will use in future.)


I thus find Freshphone's quality unreliable, for when I call land lines. I have made a number of calls to cell phones today, so the problem seems to only be with land lines.

Hi Aidan


Yes, I looked at both calls, the second call had bad Jitter from our SIP server to you. There was also packet loss on both calls. I see you are using Zoiper....try use Zoiper Pro with the g729 codec


First call, not bad Jitter


Second call, very bad Jitter


Thank you. The date today is 29 Nov 2019.

I first phoned 0216837821 for 24s at 08:14, because that number was a problem yesterday, but today it was perfect.


Then, I phoned 0216743134 for 15s at 08:17, because I remember that number being a problem in the past. Sure enough, the incoming audio was garbled. I asked them whether they could hear me properly (so you may be able to hear their response - I couldn't understand it). My Zoiper5 app (version 5.2.28 for Linux 64bit) on my Linux Mint 19.1 Tessa 64-bit computer (kernel Linux 4.15.0-70-generic x86_64) tells me that the local codecs for the call was Opus/16000 and remote codecs also Opus/16000, with the call quality rated "excellent".

Hi Aidan


I will need to get our SysOps team to activate the tracing software on our sip1 server. I will ask them to do it at 08:00, they will turn it off again at 10:00 as it is resource intensive. please test call during this time and we will trace it. 


1 person likes this

Fresh Man, the reason why I posted a message here was so that you could run a SIP trace on the call I made.

Hi Aidan


Yes, this is called Jitter. It stems from the internet connection from your device to our server ie Your internet connection. Right now your connection looks healthy

I have this same issue. For example, I called 0216715008 at 08:22 today (28 Nov 2019) for 1m33s, and the line was perfect. Then, I called 0216837821 at 08:24 today (28 Nov 2019) for 7 seconds, and what I heard was garbled (I think it's called jitter). Fresh Man, please look at this latest example.

There has to be something that is affecting it on your side. Send us a time/date of a call that this happens on and we will run a SIP trace on it to see if we can see anything strange. We need to have an example that is not older than 4 hours please.

Hi, was away on leave the last 3 weeks. Same problem. Phone one number and it's garbled, phone another one and it's fine, phone the same number that was garbled before and it stays garbled. I was using it while I was overseas now on my cellphone and the time connected doesn't show much because sometimes it would show connected for ages but there would be nothing happening, no ringing, nothing.

 

Hi Dale


Do you have anything to report back please?

Hi Fresh Man,
Sorry, no nothing to report back. To be honest I haven't really been around much to use the home phone.

 

Login or Signup to post a comment