Start a new topic
Solved

Broken voice on certain numbers only

I'm having a weird problem with my freshphone account. About half the numbers I dial are completely unusable when someone answers the phone. The line goes garbled and you can't understand a word on the other end. I use G.729 protocol and the licences and everything are sorted and all is working. 


For some reason it doesn't do this with all phone numbers. Only a handful. Any ideas? My line latency reports as 5-10ms and I've turned off the weird SIP nonsense that is supposed to be a troublemaker on the router to no avail.


Hi Aidan


I will need to get our SysOps team to activate the tracing software on our sip1 server. I will ask them to do it at 08:00, they will turn it off again at 10:00 as it is resource intensive. please test call during this time and we will trace it. 


1 person likes this

Thank you. The date today is 29 Nov 2019.

I first phoned 0216837821 for 24s at 08:14, because that number was a problem yesterday, but today it was perfect.


Then, I phoned 0216743134 for 15s at 08:17, because I remember that number being a problem in the past. Sure enough, the incoming audio was garbled. I asked them whether they could hear me properly (so you may be able to hear their response - I couldn't understand it). My Zoiper5 app (version 5.2.28 for Linux 64bit) on my Linux Mint 19.1 Tessa 64-bit computer (kernel Linux 4.15.0-70-generic x86_64) tells me that the local codecs for the call was Opus/16000 and remote codecs also Opus/16000, with the call quality rated "excellent".

Hi Aidan


Yes, I looked at both calls, the second call had bad Jitter from our SIP server to you. There was also packet loss on both calls. I see you are using Zoiper....try use Zoiper Pro with the g729 codec


First call, not bad Jitter


Second call, very bad Jitter


Hi Fresh Man


I have not yet bought Zoiper Pro (which will cost R650 I believe). Today, I had two calls to land lines that had bad jitter - 0219121800 and 0216722500, which I called at 11:09 and 11:12 respectively, lasting 9s and 4s respectively.


I then used an alternate number to call 0216722500 at 11:18 - I used my MWeb Talk number. Behold! The line had no jitter. (This indicates which provider I will use in future.)


I thus find Freshphone's quality unreliable, for when I call land lines. I have made a number of calls to cell phones today, so the problem seems to only be with land lines.

Hi Aidan


Very strange that your connectivity to our servers only suffers when calling landlines. Maybe it has to do with how its been passed onto to the landline provider, not sure. I can't recreate the issue.


I have disabled the stronger codec on your account( OPUS) and left GSM and g729( perfect call quality but you need a device or app that has this premium codec) 


Do a test call if you don't mind and see how the lesser bandwidth codec fairs.

Hi Aidan


Zoiper Premium with g729 is R218 on iOS

Thank you for changing the codec. Note that I use this number on Linux Mint and Windows desktop computers, with the Zoiper program.

Hi Dale


Upon further investigation we conclude that the issue must lie with the connection to the internet.


If it works 80 percent of the time, it is not the device, or your account


If you have a good healthy internet connection ( not necessarily speed ) then Freshphone calls will be crystal clear

Hi Fresh Man,
I am using an Asus RT-AC68U running latest Merlin firmware. I have tried with SIP passthrough turned on and off. I have tried QoS on with VOIP prioritised, at the bottom, in the middle and QoS off. It was doing the same thing when I was running on a 10Mbps Openserve fibre line as it is now doing on a Vumatel 50Mbps line. The Equipment is a Yeastar TA100.

I have tried it on Zoiper and even straight through my Android phone using it's built in SIP protocol. It does the same garbled nonsense on everything. I would tend to agree with you that it could be internet, but then it's been tried on 2 fibre lines, and then my phones LTE connection as well. You can phone one number and it's garbled, phone another number and it's crystal clear, then phone the other number again and it's garbled. That doesn't seem like internet connection to me.

I think it's a problem, possibly not even on your side, but maybe even on the switch from VOIP to analog or however it gets done to non-VOIP numbers.

 

Hi, was away on leave the last 3 weeks. Same problem. Phone one number and it's garbled, phone another one and it's fine, phone the same number that was garbled before and it stays garbled. I was using it while I was overseas now on my cellphone and the time connected doesn't show much because sometimes it would show connected for ages but there would be nothing happening, no ringing, nothing.

 

There has to be something that is affecting it on your side. Send us a time/date of a call that this happens on and we will run a SIP trace on it to see if we can see anything strange. We need to have an example that is not older than 4 hours please.

Hi Dale


We run this same platform on hundreds of thousands of extensions, it's definitely not on the switch from VoIP to analog. I have it on my Android phone and it works 100% as long as I have good signal, otherwise it can be garbled. Your incoming calls seem to be long conversations that are unaffected.


I know that if I add your account to my phone it would work perfectly ( I do have great signal where I am at the moment)


There has to be something that is affecting it on your side. Send us a time/date of a call that this happens on and we will run a SIP trace on it to see if we can see anything strange. We need to have an example that is not older than 4 hours please



Hi Dale, I see only 6 outbound calls on your account, how many of them were issues and to which destinations eg: 011 or 086 etc

I'll give it a try and let you know.

 

Login or Signup to post a comment